Solving SNMP problems

SNMP Agent User Guide for VSP E Series

Version
93-07-2x
93-07-0x
93-06-8x
Audience
anonymous
Part Number
MK-97HM85027-11

This topic describes some problems that can occur with SNMP.

Problem

Causes and solutions

Information cannot be received by GET REQUEST, GETNEXT REQUEST, and GETBULK REQUEST operations.

Causes:

  • An SNMP Manager IP address and community or user have not been added.
  • GUM failure occurred.
  • A network environment error occurred.

Solutions:

Trap cannot be received.

Causes:

  • A network environment error occurred.
  • An SNMP Manager IP address and community or user have not been added.
  • A license is invalid.
  • A GUM status error continues after a failure or maintenance operation.

Solutions:

  • Fix the network environment error.
  • Add an IP address and community or user. (See Adding trap notification for SNMP v1 and v2c or Adding trap notification for SNMP v3.)
  • Enable the license.
  • Reboot the GUM.
  • Perform the following operations:
    • Restart the SNMP Manager, or reregister the storage systems to be monitored on the SNMP Manager.
    • Confirm that traps can be reported. (See Testing SNMP trap reports.)
    • Obtain the trap history in MIB raidExMibTrapListTable from the SNMP Manager, and then perform proper storage management for traps that are not yet confirmed. For details about the format of the trap history, see raidExMibTrapListTable.