Problem:
A virtual machine has been restored, now it is no longer included in backups.
Cause:
When selecting a virtual machine explicitly (via browse) in a Hyper-V classification, Protector will refer to this VM via its ID. Restoring a virtual machine assigns a new ID to the restored VM. As the classification still refers to the original ID, the restored VM will not be included in the backup.
Solution:
Update the Hyper-V classification to include the restored VM and re-activate the data flow.