Problem:
The following message is displayed by SRM when performing a test or real fail-over or fail-back recovery operation:
Failed to sync data on replica devices.
Cause:
Cannot process consistency group '{<CTG ID>}' with role 'promotedTarget' when expected consistency group with role 'target'
Cause:
SRM checks that replications are in the expected state before performing the recovery operation. This message may be generated if the continuous TrueCopy replication between the production and recovery site has been paused or swapped outside of SRM.
SRM replications must not be paused or swapped outside of SRM.
Solution:
In SRM, perform Discover Devices, then check the Status of the datastores. If the status is Failover complete, check if the corresponding TC replication in Protector is in the paused state and un-pause it if required.
Datastores status should be either Outgoing Replication or Incoming Replication before starting a failover.